Skip to content
Magic Prices: Price Comparison
Best Deals

Snom D150 IP phone Grey 2 lines TFT

Snom D150, IP Phone, Grey, Wired handset, Desk/Wall, Linux, 2 lines

Best offerPrice trend

£54.62

-28%
Price trend
Detailed analysis ›
Price history of Snom D150 IP phone Grey 2 lines TFT over the last 3 months
DatePrice
17 July 2026£75.89
17 July 2026£61.93
31 July 2026£75.89
31 July 2026£61.93
8 August 2026£75.89
8 August 2026£61.93
9 September 2026£75.89
9 September 2026£61.93
20 September 2026£75.89
20 September 2026£61.93
26 September 2026£65.54
26 September 2026£54.62
3 October 2026£54.62

Compare Snom D150 IP phone Grey 2 lines TFT prices UK

*Date of last price update

User Notice: We regularly reference new offers to provide you with the widest selection. However, the displayed results do not reflect all available offers on the market. By default, offers are sorted by price, with the lowest price appearing first.

Product Information

Finished in slate grey and with an uncluttered design, the Snom D150 fits perfectly into any work environment where phone communication is paramount. It combines the latest technology and the best voice quality at an unbeatable price. The D150 feels at home wherever efficiency and optimum costs are required. The highly visible, backlit LED display makes it easy to monitor information on calls and features. The Snom D150 is equipped with a gigabit switch with PoE support and an RJ9 headset port.

360° notification indicator
The Indicator lamp shows from any point in the room if you have missed a call, for example.

2,8" TFT LCD - Grayscale Display
The Snom D150 is equipped with a high resolution 2.8" TFT LCD - grayscale display, which ensures an optimal display at any time.

4 context sensitive function keys + 2 freely programmable SmartLabel keys

IP Phones Snom

Product

Name
Snom D150 IP phone Grey 2 lines TFT
Category
IP Phones
Brand
Snom

Display

Touchscreen
No
Display
TFT
Display diagonal
7.11 cm (2.8")
Display resolution
320 x 240 pixels

Phone features

Lines quantity
2 lines
Answering machine
Yes
Call waiting
Yes
Speed dialling
Yes
Intercom
Yes
Call hold
Yes
Redialing
Yes

Operational conditions

Operating temperature (T-T)
0 - 35 °C
Operating relative humidity (H-H)
5 - 95%
Storage temperature (T-T)
-10 - 45 °C

Weight & dimensions

Width
185 mm
Depth
205 mm
Height
40 mm
Height (min)
4 cm
Height (max)
22 cm

Power

Power over Ethernet (PoE)
Yes
AC adapter input voltage
100 - 240 V
Input frequency
50 - 60 Hz
AC adapter output voltage
5 V
AC adapter output current
2 A
Power consumption (typical)
10 W

Ports & interfaces

Headset connectivity
RJ-9
Ethernet LAN (RJ-45) ports
2
RJ-9 ports quantity
2

Network

Ethernet LAN
Yes
Ethernet LAN interface type
Gigabit Ethernet
Supported network protocols
IPv4 / IPv6 (dual stack), DHCP, NTP, LDAP, LLDP-MED, HTTP, TFTP, L2TP
Security algorithms
HTTPS, SIPS, SRTP, TLS
VoIP protocols
SIP (RFC 3261), SDP (RFC 3261), RTP (RFC 8866), RTCP (RFC 3550), RTCP-XR, SIP REFER method (RFC 3515), rport (RFC 3581), ENUM, ICE, STUN (RFC 5389)
Networking standards
IEEE 802.3af, IEEE 802.3az

Audio

Microphone mute
Yes
Voice codecs
G.711alaw, G.711ulaw, G.722, G.726, G.729, GSM 6.10
Voice activity detection
Yes
Comfort noise generation (CNG)
Yes

Packaging content

Number of handles included
1 pc(s)
Ethernet cable
Yes
Stand included
Yes

Performance

Operating system installed
Linux

Design

Product type
IP Phone
Product colour
Grey
Handset type
Wired handset
Device lock
Yes
Wall mountable
Yes
Mounting
Desk/Wall

Management features

Keypad number of keys
36
Number of function keys
6

Customer Reviews

Share your opinion on the product or read reviews from other members.