Skip to content
Magic Prices: Price Comparison
Best Deals

Cambium Networks EX2028-P Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey

Cambium Networks EX2028-P, Managed, L2, Gigabit Ethernet (10/100/1000), Power over Ethernet (PoE), Rack mounting, 1U

Best offerPrice trend

£1,268

-17%
Price trend
Detailed analysis ›
Price history of Cambium Networks EX2028-P Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey over the last 3 months
DatePrice
26 September 2026£1,519
26 September 2026£1,266
29 September 2026£1,268

Compare Cambium Networks EX2028-P Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey prices UK

Product Information

Cambium Networks EX2028-P. Switch type: Managed, Switch layer: L2. Basic switching RJ-45 Ethernet ports type: Gigabit Ethernet (10/100/1000), Basic switching RJ-45 Ethernet ports quantity: 24, Installed SFP+ modules quantity: 4, USB 2.0 ports quantity: 1. MAC address table: 16384 entries, Switching capacity: 128 Gbit/s. Networking standards: IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE.... Power over Ethernet (PoE). Rack mounting, Form factor: 1U

Network Switches Cambium Networks

Product

Name
Cambium Networks EX2028-P Managed L2 Gigabit Ethernet (10/100/1000) Power over Ethernet (PoE) 1U Grey

Ports & interfaces

Basic switching RJ-45 Ethernet ports quantity
24
Basic switching RJ-45 Ethernet ports type
Gigabit Ethernet (10/100/1000)
Installed SFP modules quantity
0
Installed SFP+ modules quantity
4
Installed QSFP+ modules quantity
0
USB 2.0 ports quantity
1

Network

Networking standards
IEEE 802.1D, IEEE 802.1Q, IEEE 802.1ab, IEEE 802.1p, IEEE 802.1s, IEEE 802.1w, IEEE 802.1x, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ac, IEEE 802.3ad, IEEE 802.3ak, IEEE 802.3u, IEEE 802.3x
Flow control support
Yes
Broadcast storm control
Yes
Auto MDI/MDI-X
Yes
VLAN support
Yes
Number of VLANs
4094

Power

Power supply included
Yes
AC input voltage
100 - 230 V

Operational conditions

Operating temperature (T-T)
0 - 50 °C
Storage temperature (T-T)
40 - 70 °C

Weight & dimensions

Width
440 mm
Depth
250 mm
Height
44 mm
Weight
3.96 kg

Security

DHCP features
DHCPv6 snooping
Access Control List (ACL)
Yes
IGMP snooping
Yes
IGMP proxy
Yes
Security algorithms
802.1x RADIUS
MAC address filtering
Yes
Static port security
Yes
SSH/SSL support
Yes
Password protection
Yes
Authentication type
RADIUS

Data transmission

MAC address table
16384 entries
Switching capacity
128 Gbit/s
Throughput
128000 Mpps
Packet buffer memory
1.5 MB

Management features

Switch type
Managed
Switch layer
L2
Quality of Service (QoS) support
Yes
Web-based management
Yes
ARP inspection
Yes
Configuring Location Settings (CLI)
Yes
System event log
Yes
User operation log
Yes

Protocols

Management protocols
SNMP v1, v2, and v3, SSH 1.5 and 2.0, RFC 4252: SSH, RFC 4253: SSH,• RFC 4254: SSH, RFC 4251: SSH, RFC 4716: SECSH, RFC 4419, SSL 3.0, RFC 2246, RFC 2818, RFC 3268

Power over Ethernet (PoE)

Power over Ethernet (PoE)
Yes
Power over Ethernet (PoE) ports quantity
24
Power over Ethernet (PoE) power per port
30 W
Total Power over Ethernet (PoE) budget
400 W

Design

Rack mounting
Yes
Form factor
1U
Product colour
Grey
LED indicators
Link, PoE
Number of fans
2 fan(s)

Performance

Internal memory
512 MB
Flash memory
128 MB
Mean time between failures (MTBF)
285350 h

Customer Reviews

Share your opinion on the product or read reviews from other members.