Skip to content
Magic Prices: Price Comparison
Best Deals

Allied Telesis AT-GS950/48-50 Managed L2 Gigabit Ethernet (10/100/1000) 1U Grey

Allied Telesis AT-GS950/48-50, Managed, L2, Gigabit Ethernet (10/100/1000), Rack mounting, 1U

Best offerPrice trend

£726

Rising
Price trend
Detailed analysis ›
Price history of Allied Telesis AT-GS950/48-50 Managed L2 Gigabit Ethernet (10/100/1000) 1U Grey over the last 3 months
DatePrice
15 July 2026£717
21 July 2026£690
30 July 2026£722
5 August 2026£712
15 August 2026£706
22 August 2026£700
2 September 2026£707
10 September 2026£706
16 September 2026£708
23 September 2026£716
30 September 2026£722
9 October 2026£725
12 October 2026£726

Compare Allied Telesis AT-GS950/48-50 Managed L2 Gigabit Ethernet (10/100/1000) 1U Grey prices UK

Product Information

The Allied Telesis AT-GS950/48 eco-friendly WebSmart switch upholds the Allied Telesis commitment to environmentally friendly processes and products. It is designed to minimize power consumption through the use of a high-efficiency power supply and a low power chipset.

The AT-GS950/48 features 48 x 10/100/1000T ports and an additional four Gigabit SFP combo ports. This WebSmart switch integrates the simplicity of unmanaged switches with the performance and reliability of managed switches to provide a cost-effective solution for users to integrate management at the edge of their network. The AT-GS950/48 provides key features using the simple web-based management function, such as port-based VLANs, IEEE 802.1p QoS, port trunking/link aggregation, port mirroring, priority queues, and IEEE 802.1x security support.

Network Switches Allied Telesis

Product

Name
Allied Telesis AT-GS950/48-50 Managed L2 Gigabit Ethernet (10/100/1000) 1U Grey

Ports & interfaces

Basic switching RJ-45 Ethernet ports quantity
48
Basic switching RJ-45 Ethernet ports type
Gigabit Ethernet (10/100/1000)
Combo SFP ports quantity
4
Console port
RJ-45
Power connector
DC-in jack

Network

Networking standards
IEEE 802.1D, IEEE 802.1p, IEEE 802.1Q, IEEE 802.1w, IEEE 802.1x, IEEE 802.3, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3i, IEEE 802.3u, IEEE 802.3x, IEEE 802.3z
10G support
No
Copper ethernet cabling technology
1000BASE-T, 100BASE-TX
Port mirroring
Yes
Flow control support
Yes
Link aggregation
Yes
Broadcast storm control
Yes
Rate limiting
Yes
Auto MDI/MDI-X
Yes
Spanning tree protocol
Yes
Head-of-line (HOL) blocking
Yes
VLAN support
Yes

Power

AC input voltage
100 - 240 V
AC input frequency
50 - 60 Hz

Operational conditions

Operating temperature (T-T)
0 - 40 °C
Storage temperature (T-T)
-25 - 70 °C
Operating relative humidity (H-H)
5 - 90%
Storage relative humidity (H-H)
5 - 95%

Weight & dimensions

Width
444 mm
Depth
322 mm
Height
43.5 mm
Weight
4.05 kg

Security

DHCP features
DHCP client
IGMP snooping
Yes

Data transmission

MAC address table
8000 entries
Throughput
14.88 Mpps
Jumbo frames support
Yes
Packet buffer memory
6 MB

Management features

Switch type
Managed
Switch layer
L2
Quality of Service (QoS) support
Yes
Web-based management
Yes
MIB support
RFC 1213, RFC 1643, RFC 1493

Protocols

Management protocols
IGMP, SNMP, FTP

Power over Ethernet (PoE)

Power over Ethernet (PoE)
No

Design

Rack mounting
Yes
Form factor
1U
Product colour
Grey
LED indicators
Yes

Performance

Internal memory
32 MB
Flash memory
4 MB
Mean time between failures (MTBF)
263000 h

Logistics data

Harmonized System (HS) code
85176990

Multicast features

Multicast support
Yes

Certificates

Certification
UL 1950, FCC/EN55022, VCCI, C-Tick, EN60950, EN55024, CE, CSA, CUL

Customer Reviews

Share your opinion on the product or read reviews from other members.